Problèmes à l’installation sur serveur

  Le répertoire tmp/cache


- Vérifier la bonne exécution des transferts (par spip_loader)
- Supprimer les fichier du répertoire tmp/cache résout moult problèmes !

 
 
 
 
 
 
 
 
 
 

 Un exemple vécu [1]

Ça y est, j’ai mis le site de l’association pour laquelle je travaille en ligne.
Après avoir bien travaillé en local avec EasyPHP, j’ai fait le saut !
C’est Webou.net qui héberge.

Donc installation de SPIP, non pas par spip_loader, mais par transfert (Outils FTP pour Webmestre) des fichiers du package SPIP sur le serveur.
Ensuite, je récupère la sauvegarde faite en local et fait une restauration sur le serveur.

Là, malheur, Mises à jour..... à problèmes ? ! la page d’accueil affiche l’entête du site puis une ligne d’erreur.

Après lancement d’une bouteille à la mer (Débuter, c’est ’terrible’) sur la liste spip@rezo.net, je reçois un conseil sur le couteau suisse [2] ; mais dès que je valide une modification de lame, c’est le naufrage : plus rien, sauf une erreur à propos d’un fichier sur tmp/cache/charger_pipelines.php [3].

Coulé pour coulé, j’utilise FTP pour supprimer tous les fichiers du répertoire ./tmp/cache.
Miracle c’est reparti comme en local !

Donc en cas de problèmes graves, ne pas hésiter à nettoyer ce répertoire et j’ai déjà lu avec spip@rezo.net que d’autres ont résolu leurs problèmes en faisant ce petit ménage.

 D’autres risques

Controler la Check-liste d’installation SPIP, car les transports de site peuvent mettre au jour plusieurs problemes : FTP
- les versions de PHP qui diffèrent : Des cas..... résolus ! PHP5
- les versions de SGBD distinctes (comme une installation SQLite passée en MySQL)
- l’ecrasement et l’action sur un autre jeu de tables (quand on ré-installe sur un meme serveur) : confusion de prefix.

La bonne précaution quand on installe un SPIP : effacer les fichiers et répertoires
- de connection : renommer ./config/connect.php
- de cache : vider par ./tmp/cache/ (Connexion impossible.... cache hé ?)
- suspendre les plugins en renommant./plugins
(penser à le rétablir pour ré-activer les plugins avant de recharger une sauvegarde de la base de données)
- et penser ensuite à visualiser/valider le pavé initial de Configuration/Identité pour valider le chemin physique réel du site.


Merci de nous signaler les coquilles ou erreurs qui figureraient dans cette page.

[1Merci à son auteur de nous avoir rapporté cette expérience !

[2La panne n’est pas due au CS, mais cela permet d’avancer dans le diagnostic..

[3Il s’agirait d’une saturation disque serveur : voir Connexion impossible.... cache hé ?.


Liens visibles seulement pour les inscrits.

Article publié le 6 juillet 2012, et actualisé en octobre 2014 .

Répondre à cet article